NVidia 2060 RTX Low framerate

peteramour
Posts: 12
Joined: Sun Mar 12, 2017 10:27 pm

NVidia 2060 RTX Low framerate

Post by peteramour » Tue Feb 18, 2020 10:41 pm

Hello,

I bought a new computer with high specs, Lenovo Y540: i7 9750, Nvidia RTX2060, 32Gb Ram, and i am strugling to get Aerodrums to 125 fps. I have disabled Vertical Sync with no luck... If I use the 3D beta it works like a charm, giving me a count of 999fps, but in standard Aerodrums interface is alwyas jumping between 48 to 60 FPS!
I changed a lot of settings in the Nvidia 3d aplication and still no luck. what am i missing here?
Hep would be very much apreciated!

Richard
Posts: 779
Joined: Wed Feb 26, 2014 1:45 am

Re: NVidia 2060 RTX Low framerate

Post by Richard » Wed Feb 19, 2020 11:41 am

Is it the case that the frame rate hovers round 60 FPS but never goes above it? If so, that's a telltale sign that Vertical Sync is the issue.

I don't know if your laptop has an Intel integrated graphics card in addition to the Nvidia card but if it does are you sure that it's using the Nvidia card to run Aerodrums? To check this, right-click on aerodrums.exe in File Explorer and see if there is a menu item named "Run with graphics processor" that lets you choose between Intel graphics and Nvidia.

Can you also try press Ctrl+G while on the Aerodrums drumming screen. This will cycle through various lower quality/higher performance graphics mode. Graphics mode #4 will disable graphics entirely - in this case the title bar of the Aerodrums window will display the FPS value. Can you try this to see if it reads 125 FPS in this case?

peteramour
Posts: 12
Joined: Sun Mar 12, 2017 10:27 pm

Re: NVidia 2060 RTX Low framerate

Post by peteramour » Thu Feb 20, 2020 11:51 am

First of all, thank you for the reply and tips.

I have been doing a lot of testing regarding my issue because it is really intriguing as you will see in my long long long description of the issues I am stumbling upon.
I am a long time user of your software, and a very happy one, in my older Macbook Pro. But the system is 10 years old and I needed professionally a newer and more capable system and to my available budget i decided to choose the PC i described in the previous post, a Lenovo Y540. Been working great in my main use for it (video and photo editing), but for Aerodrums I am struggling to get the performance he is able to provide.

Just as a side note, I am not an Apple fanboy, I don´t even care. But based in my experience with both systems, there is one thing that is really better in an Apple Mac OSX system: the audio and midi architecture and implementation. Stable universal drivers, no installations needed, shared audio and midi (this is a must for me), great midi implementation and midi over network, all of this out of the box in the OS. No third party software.
As for windows... No internal midi routing (LoopBe needed), third party ASIO drivers needed for low latency (WASAPI is not supported yet for some software I use), no low latency audio out of the box (ASIO4All needed), no shared audio drivers, third party software needed like the no longer supported, "oldish" and outdated and difficult to understand interface and functioning ODeus ASIO Link. Come on Microsoft!!! Can´t I play and listen to a video in my browser when my DAW is using the sound card with ASIO drivers???), This is just an outburst that has nothing to do with you and your team. As i said, a side note in Mac OSX vs Windows.

Answering to your recomendations:
I only have one graphics card, my laptop doesn´t have a 2nd card, so i dont need to force its usage.
In task manager I can see it is being used by aerodrums.exe. I think the graphics card selection option doesnt even appear in my system.
I cycled through all gfx modes, with little to no noticeable difference in my frame dropping problem.
The frame rate is not stuck at 60fps, I have vertical sync turned off.
My flutuations of FPS are very inconsistent, they flutuate a lot between 100 and 125, sometimes they drop to 90 and 80. Anyway, the red sign is always turning on. The usability of the system is bad with random not desired hits when I play.
One thing I haven´t mentioned is that my display is 144Hz refresh rate. Don´t know if this could be an issue...

And now my strange findings in the search for solutions to my problem,

1) I tried a lot of things, had some minor improvements turning non-microsof services off in "msconfig", and disabling startup items in boot.

2) Reinstalled graphics drivers, clean installation option turned on. Uninstalled and reinstalled Aerodrums 2 times. Rebooted a lot of times. No difference. In task manager i changed Aerodrums process priority behaviour to above average to realtime. No difference.

3) Now the weird part is about to being described from this point on.

4) Using Aerodrums 3D, I can get to 999fps!! Very good performance (fastest settings selected). Every hit detected perfectly.
But...
It overcharges the graphic card to 100%.
I figured out that I needed to limit the framerate of Aerodrums3D in NVIDIA control panel 3D Settings to about 500 fps and the GPU is at about 50% to 60% with perfect performance in drumming. Limiting below that framerate, bad and inconsistent drumming performance. So the 500 fps seems to be a good compromise between the GPU and drumming performance.
But...
The good performance only happens as long I have the Aerodrums 3D software in "focus". In the moment I use my mouse in other software, even in desktop or file explorer, the framedropping and performance issues start. I dont know what is happening but its like the processing priority goes imediatelly down in the moment the window is not in focus.
For me, being able to use Aerodrums standard or 3D with other softwares is essential for midi recording in a DAW, to playalong with external music libraries like iTunes, and to play with external drum samples software like EZDrummer.

5) Now the really weird part. Yes... there is more....
When I boot my system, if I immediately turn on Aerodrums (from now on I will refer as only "Aerodrums" to the standard non 3D) and start playing it, the framerate is spot on at 125fps. In wichever gfx mode. Perfect performance. I can even "unfocus" Aerodrums window that there is no performance degrading, always 125 fps, green light on. For about 2 or 3 minutes. After that the frame dropping reappears. WHAT????

6) I tried a lot of things, being one of them experimenting with the windows compatibility settings in aerodrums.exe. Tried a lot of combinations with settings like "Disable full-screen optimisations", "Run this program as administrator", Run this program in compatibility mode for Windows 8", even combinations with options in "Change high DPI settings".
The results i can report is that with some combinations of settings, when I started Aerodrums, I had the same good performance as when I boot, but also for only a few minutes. And when I replicated the exact combination of settings, when Aerodrums opened the performance issues were already there. So it is very random.

7) As it seems to be a graphics related issue I went and experimenting with NVIDIA Control Panel 3D settings for Aerodrums.exe. After a lot of combinations on all those settings, no performance difference.
But...
The only common thing or pattern i noticed is this strange behaviour: whenever I hit "Apply" in Nvidia Settings, those 3 to 5 seconds the settings are being applied, the Aerodrums software performs at a non drop 125 fps, always green, detecting perfectly every single hit i try to cram in that little time window. What???

8) I want to perform some more testing with a clean Windows installation, perhaps in an external or secondary hard drive, since for now its not possible for me to completely format my PC as i have work in progress. I would like to understand if it is something I have installed that is causing issues. I use Adobe Creative Cloud software and i am aware that it is system hungry and starts a lot of services in background, so I normally shut it off in Aerodrums session.

9) Could it be a processing priority behaviour in the GPU? In my monitoring Aerodrums uses about 30% of GPU.
Can I force the software (non 3D) to be always using more than 50% of the GPU as it seems that in 3D mode that solves part of the issues? Could it be some Windows setting in background tasks priory, since when it looses window focus the performance also degrades? I dont know... thats why I am reporting to you all of this... Maybe you know how to fix it... If not at least you now are aware of possible issues your users may encounter...

I could be describing some other few things I tried, but at this point I think it is clear of this erratic and random performance behaviour that is happening in my system with Aerodrums. Everything else in my computer is not having any kind of performance issue. I know it´s not a scientific measurement, but for your information, sometimes i play modern 3D games at 1080p with ultra settings and everything goes smooth.

If you would like I can record me and my screen as I go through some things I described so you can see exactly what´s going on, but for now I think this is a very thorough and detailed description of the issues. We could also continue this conversation by email if you prefer.

Well that´s it for now... I am trying to be as descriptive as I can, as i am not a native english speaker, and i am hoping that we, together, can find a solution.

Thank you very much.

Richard
Posts: 779
Joined: Wed Feb 26, 2014 1:45 am

Re: NVidia 2060 RTX Low framerate

Post by Richard » Thu Feb 20, 2020 5:31 pm

Thanks for the in-depth description.

I assume you have tried to run Aerodrums with nothing else running (DAW, Adobe, etc.) after a reboot and the frame rate still didn't hit 125?

Just so you know, the performance issue isn't so much related to graphics - the USB camera needs to be able to stream frames at 125 fps and this is why Aerodrums is relatively demanding.

I'm a bit confused by the stuff about Aerodrums 3D given that Aerodrums 3D is just an optional visual front-end and doesn't reduce the work that Aerodrums has to do. Are you saying that with Aerodrums 3D running in addition to Aerodrums on the same computer that you're able to drum properly, i.e. that the Aerodrums frame rate is stable at 125?

...when Aerodrums 3D is running, Aerodrums basically disables its graphics which is equivalent to "Graphics Mode #4". So I would be very surprised if things work better with Aerodrums 3D running, compared to using Ctrl+G to disable Aerodrums' graphics. But please confirm if that's definitely the case for you.

Regarding (4), by default Aerodrums 3D does not impose a limit on the frame rate so that the animation is as smooth as possible. However, there is a setting under the 'View' menu of Aerodrums 3D where you can limit the FPS to 30 or 60. There are other settings that I also recommend enabling such as switching to 'Partial anim' mode which will basically avoid rendering the full 3D drum kit each frame (see the 'Performance' section of https://aerodrums.com/3d-update/)

Keep in mind that you can also run Aerodrums 3D on an Android or iOS phone/tablet if that's an option to further reduce the load on your computer.

But again, I don't really understand how Aerodrums could perform better with Aerodrums 3D running than without...

peteramour
Posts: 12
Joined: Sun Mar 12, 2017 10:27 pm

Re: NVidia 2060 RTX Low framerate

Post by peteramour » Thu Feb 20, 2020 8:38 pm

Thanks
I assume you have tried to run Aerodrums with nothing else running (DAW, Adobe, etc.) after a reboot and the frame rate still didn't hit 125?
Yes I did. As i said i have booted with only microsoft services enabled and no extra software running besides Aerodrums.
when Aerodrums 3D is running, Aerodrums basically disables its graphics which is equivalent to "Graphics Mode #4". So I would be very surprised if things work better with Aerodrums 3D running, compared to using Ctrl+G to disable Aerodrums' graphics. But please confirm if that's definitely the case for you.
You can be surprised as I am, that´s exactly what happens. Aerodrums 3D performs better, only and only if it´s window is in focus, also as I said.
However, there is a setting under the 'View' menu of Aerodrums 3D where you can limit the FPS to 30 or 60. There are other settings that I also recommend enabling such as switching to 'Partial anim' mode which will basically avoid rendering the full 3D drum kit each frame (see the 'Performance' section of https://aerodrums.com/3d-update/)
Yes I have tried that, didn't mention in my previous post. When i use limit to 60fps or 30fps I have all the sluggish performance issues described. The only way that I can limit Aerodrums 3D framerate is in Nvidia Control Panel 3D settings, and it only works flawlessly if i limit it at 500 frames or above. I tried 125 and 250 below that and I also have the performance issues described.
Keep in mind that you can also run Aerodrums 3D on an Android or iOS phone/tablet if that's an option to further reduce the load on your computer.
I tried and it connects, but since that is not a solution form me i didn't pay much attention to performance, i only opened it just to check if it connects and responds to my movements and it does, but can't tell if the performance is good, i didn't used with that in mind... Anyway I want to use the computer as my central piece of hardware, so more devices is not a route i want to take.
But again, I don't really understand how Aerodrums could perform better with Aerodrums 3D running than without...
But it does. And I am also surprised with that.

I can understand this is really weird issue, but I can assure you that what I described is exactly what is happening. I consider myself an advanced computer user, as a professional in creative digital content creation, I studied computers in university and I work for 10+ years daily with computers. So I can assure you that its not a "user" problem so that we don't loose anymore time exchanging messages where we repeat ourselves.

As I said, If needed i will record a video describing and showing exactly what happen and it seems it´s needed. Its ok i am surprised also with this behavior and probably wouldn't believe it if i didn't experienced it or seen it.

So if you don't mind give me a day or two so i can record the problems in a video format to share it with a link in here.

Thanks

peteramour
Posts: 12
Joined: Sun Mar 12, 2017 10:27 pm

Re: NVidia 2060 RTX Low framerate

Post by peteramour » Fri Feb 21, 2020 3:43 pm

As promised here is the video showing exactly the issues so you can see it.
It is a little long but it goes step by step into the issues I described.

https://photos.app.goo.gl/rVbzgatQ6tqpWGzM9


Hope this helps, just add this visual information to the already textual description of the issues.

Waiting to hear back from you,
Thanks,

P.S.: In the part where i limit my framerate to 500fps i didnt get back to gpu monitoring in task manager, but you can see it in the left bottom of the recording when it enters the frame, it´s now at about 50% usage, instead of 94% before it was limited.

Richard
Posts: 779
Joined: Wed Feb 26, 2014 1:45 am

Re: NVidia 2060 RTX Low framerate

Post by Richard » Tue Feb 25, 2020 10:10 pm

Sorry for the delay, I missed your reply and thanks for sharing this video.

My suspicion is that this is related to the power management settings of your NVIDIA card.
I believe it's dynamically changing clock speeds, etc. to reduce how much power it's consuming. This adaptation is based on how much load is being placed on the graphics card by applications using it.

So when you run Aerodrums 3D at 500+ FPS the graphics card suddenly puts itself in "high performance mode" and when it is less stressed (e.g. when Aerodrums 3D isn't running) it starts performing poorly in an effort to conserve power.

The first thing I'd say is that it's a good idea to plug your laptop into mains power if you've been doing your experiments running off battery. In my experience, the default behaviour of NVIDIA cards is to run in a lower performance mode when running off battery.

But regardless of that, have you experimented with the "Power management mode" setting in the NVIDIA control panel? You should find an option there called "Prefer maximum performance" (or similar) that you can enable for Aerodrums.exe and hopefully prevent it from throttling performance.

Please try that and let us know how it does. Thanks.

peteramour
Posts: 12
Joined: Sun Mar 12, 2017 10:27 pm

Re: NVidia 2060 RTX Low framerate

Post by peteramour » Wed Feb 26, 2020 12:51 am

Thanks,

All my testing was done with the charger plugged in.

Changed in NVIDIA to maximum performance in power management, nothing happened, still bad performance. Rebooted and nothing changed.

With your tip of the issue being power management related I went to power options in windows and changed in advanced options the pci express link state power management to off, it was in "maximum power savings", but stil no difference.

I am really sad with this...
How is it possible a recent pc with good hardware struggle with Aerodrums?
I really dont know what can i do....
For my bad luck my old Macbook Pro that can run Aerodrums nicely, has the charger broken, so i cant even turn it on now.

Richard
Posts: 779
Joined: Wed Feb 26, 2014 1:45 am

Re: NVidia 2060 RTX Low framerate

Post by Richard » Wed Feb 26, 2020 1:09 am

That's a pity. I was sure it was an NVIDIA power management issue because it would explain all the behaviour you showed in your video.

Maybe you tried it but if you haven't, I think it's worth changing the Aerodrums.exe settings in NVIDIA control panel to use the other power options: "NVIDIA driver-controlled" and "Prefer consistent performance" to see if they give a different result.

As a test, you could also try set "Prefer maximum performance" globally (as opposed to for Aerodrums.exe only) to see if it works.

peteramour
Posts: 12
Joined: Sun Mar 12, 2017 10:27 pm

Re: NVidia 2060 RTX Low framerate

Post by peteramour » Thu Feb 27, 2020 11:06 am

Hello, thanks again.

I have tried that, and tried again after your recommendation.
Didn´t work.

Meanwhile I continued my quest to find out whats going on.

AND I HAVE GOOD NEWS!!

By pure chance I found out a workaround.... Not a 100% solution but it get´s me stable 125 framerate.

Lenovo has an official "command center" software for their computers, called Lenovo Vantage. There you can control some settings related to power management, audio, video and webcam options.

I was messing around over there to see if changing some settings would make a difference, and as i said, by pure chance (and a little persistence), when a look to Aerodrums window it displayed stable 125fps. I went back to see what option made a difference, and for my surprise it wasn´t any option at all.

It´s an Interface Tab related to "Display & Camera". As long that tab is selected Aerodrums performs flawlessly. If i get out of that interface tab, frames drop imediatelly.

My suspicion is it is related with somekind of conflict with the computer webcam, because in that tab we see the image from the webcam and we can control some settings.
The only drawback of this is that I can´´t change to another Windows Desktop, Desktop 2 or Desktop 3 and so on... The framerate drops instantly.

I leave here the video so you can see exactly what i am talking about.
https://photos.app.goo.gl/yGQf3oBMTCmjW3HJA


After this I still don´t understand why this happens, i suspect it has to do with some hardware/driver setting of my laptop conflicting aerodrums driver/camera, but this is to generic...

Maybe your developers team can figure it out, or contact Lenovo to understand what is happening here so that it doesn´t happen again to any other user...

Well... Thanks for your availability in trying to help, I am available to help you out if you want to go deeper with this, just contact me!

Kind regards

Post Reply