Page 1 of 1

No sound when using alone or when triggered with AD2

Posted: Sun Oct 23, 2016 10:56 pm
by BDW430
It seems like there was absolutely no communication between Aero and Addictive Drums 2 within my Reaper DAW. I could trigger sounds from AD2 when i'm in its own interface, but trying to trigger thru Aero was nonexistent. I have them both running thru ASIO and LoopBe (or so it appears). But no communication at all between the two programs. Selecting WASAPI as the alternative gets the same result as well. Even when i try to run Aero standalone (MIDI with sounds selected) it's still mute. Any ideas what it could be? Only things I've changed was rearranging my drum kit, and putting a noise gate thru Reaper (but that doesn't kill the sound all together)

Re: No sound when using alone or when triggered with AD2

Posted: Mon Oct 24, 2016 11:24 am
by Richard
I'm not sure if this will help but the order that you run the programs in matters a lot. Low latency audio devices like Exclusive WASAPI and ASIO typically require exclusive access to the soundcard. This means that if you have Reaper and Aerodrums both set to use Exclusive WASAPI and then run Aerodrums followed by Reaper, Reaper will not be able to output any audio because Aerodrums has already claimed exclusive soundcard access. (Unfortunately, this is currently the case even if you run Aerodrums in MIDI Only mode. This is an issue that we will fix.)

To get around this you should run your DAW (or whatever application is outputting the drum sounds) before running Aerodrums. This will result in Aerodrums' audio initialization failing but that's ok if you're only interested in receiving MIDI from Aerodrums. An alternative is to set the Aerodrums audio output device to 'None' and restart Aerodrums.

I suspect the reason that running "Aero standalone" wasn't working is because you still had Reaper running?
In any case, I'm hoping the following will work:
- set Aerodrums to MIDI Only mode
- close Aerodrums and Reaper
- run Reaper
- run Aerodrums

Re: No sound when using alone or when triggered with AD2

Posted: Fri Oct 28, 2016 9:14 am
by BDW430
So i downloaded the new update to Reaper...and it seemed to have made matters worse. I tried to open both programs in the order you recommended, no error message with Aero, but it just crashes Reaper every single time within seconds. I try the reverse order, still no error message on Aero...but back to the original problem of no communication between the programs, but Reaper stays open. I tried to see if maybe they were reading two different sound sources...nope. I have them both through ASIO and LoopBe. Through ASIO i have Reaper running into my headphones. Any additional ideas?

Re: No sound when using alone or when triggered with AD2

Posted: Fri Oct 28, 2016 11:22 am
by Richard
Could you try set Aerodrums to not initialize any audio device and see what happens then?
You can do this by going to the Latency screen in Aerodrums, clicking the "Change" button and selecting the "None" option. Make sure you restart Aerodrums after doing this.

In any case, I'm not convinced this is the problem. It sounds like Reaper is not receiving any MIDI data? Are you sure you set both Aerodrums and Reaper to use LoopBe?
If you download and run MIDI-OX ( you should be able to see the MIDI data coming from Aerodrums.
It wasn't clear if you answered this in your original post but if you run Addictive Drums 2 standalone (without Reaper running), are you able to trigger it through Aerodrums?

Re: No sound when using alone or when triggered with AD2

Posted: Tue Nov 01, 2016 12:22 pm
by slavedave
Apologies for an obvious question but when you are playing Addictive drums via Reaper do the hits register on the drum kit GUI in Addictive drums? If yes, then you know that the midi is getting through to Addictive Drums so troubleshooting the audio path would be the route to go. Are your ouputs in Reaper set to your Master Output on your soundcard / interface. Do other Vsts in your Reaper set up play alongside Addictive Drums (i.e. is the audio working within Reaper for the loaded project)? Can you try another drum VST in the project at the same time?

Again, sorry if you have been through all these stages already.

Re: No sound when using alone or when triggered with AD2

Posted: Fri Nov 18, 2016 9:11 am
by BDW430
Sorry i took so long to respond, guys!
So the conclusion I've come down to after trying different combinations is that:
Aero triggers sound just fine on its own when i turn on MIDI and sound
AD2 within Reaper triggers sounds on its own just fine when inside its interface.
But together...NOTHING HAPPENS. It's still as if they're totally unaware of each other.
Maybe has something to do with a Windows 10 update on my computer? It did that to AD2, but there seem to be a universal fix for it and it worked fine.