Hi hat help

Re: Hi hat help

Postby Richard » Sun May 27, 2018 5:43 pm

On the Aerodrums MIDI screen, if you tick the 'Open or closed only' option then Aerodrums will send one MIDI note for open hihats and a different MIDI note for closed hihats. If sounds like the open hihat case is working so you just need to figure out what note Logic X expects for triggering a closed hihat.

If you can figure out that note then you can edit the hihat in your Aerodrums MIDI map and specify the note to be sent for closed hihats. The default notes that Aerodrums sends are A#1 for open hihats and D0 for closed hihats so you will need to replace the D0 with whatever note triggers a closed hihat in Logic. Let me know if that's not clear. Hopefully you can figure the note within Logic or by referring to the manual. The downside is that you won't have continuous pedal control for the hihat but it sounds like the electronic kits you're using might not support this anyway.
Richard
 
Posts: 642
Joined: Wed Feb 26, 2014 1:45 am

Re: Hi hat help

Postby condordontsurf » Tue May 29, 2018 8:59 pm

thanks for your help Richard, I will continue to explore it as time allows. Nice to know that you are right there, willing to help! Sincerely.
condordontsurf
 
Posts: 11
Joined: Fri Apr 27, 2018 5:59 am

Re: Hi hat help

Postby eriklharper » Wed Jun 06, 2018 7:53 pm

I am also having this problem when trying to hook Aerodrums up to GarageBand. The default MIDI settings allow me to hit just the hi-hat open sound and the hi-hat pedal close sound, but nothing else on the hi-hat. This is very limiting and is preventing me from recording drums on a friend's scratch track. Can someone who has solved this please write up the exact steps to map the correct hi-hat midi sounds from Aerodrums to GarageBand?

Thanks
Erik
eriklharper
 
Posts: 11
Joined: Tue Jun 05, 2018 12:31 am

Re: Hi hat help [BUG]

Postby eriklharper » Wed Jun 06, 2018 10:24 pm

Richard wrote:Now select 'Hi-hat' from the list on the left and on the 'CC:' line select 'Other' and enter a value of 1. Then click Save and see if that helps.


I followed these same steps above but with a Clone of the GarageBand MIDI map, but it looks like Aerodrums isn't saving my "Other" value of "1" setting after I click Save and then go back to the home screen, then back into the MIDI Maps page for the "Clone of GarageBand" MIDI map. I've created a series of screenshots to show you this "bug":

Step1.png
Step1.png (228.63 KiB) Viewed 1762 times


Step2.png
Step2.png (179.07 KiB) Viewed 1762 times


Step3.png
Step3.png (213.27 KiB) Viewed 1762 times
eriklharper
 
Posts: 11
Joined: Tue Jun 05, 2018 12:31 am

Re: Hi hat help

Postby Richard » Thu Jun 07, 2018 8:56 pm

I can see why this looks like a bug but in fact the reason why the setting reverts to "Mod wheel" after setting a value of 1 is because mod wheel corresponds to the value 1. Similarly choosing the "Foot pedal" setting is equivalent to setting a value of 4. Really "Other" is used to set any CC value other than 1 and 4.

I just tested Aerodrums v1.1 with GarageBand v10.2.0 and the hi-hat worked fine for me, including with electronic kits. Here are the steps:

In Aerodrums:
Enable "MIDI only" mode
Tick the "Open or closed only" option (I also had the "Only send openness before note" option ticked)
Choose the GarageBand preset from the MIDI maps list

In GarageBand:
After launching, choose Empty Project
In the "Choose a track type" popup, pick Drummer (for me, this uses the SoCal kit)

If you now play Aerodrums you should hear GarageBand triggering the drums and the hi-hat should work properly.
Richard
 
Posts: 642
Joined: Wed Feb 26, 2014 1:45 am

Re: Hi hat help [SOLVED]

Postby eriklharper » Thu Jun 07, 2018 9:46 pm

I finally got Aerodrums hi-hats working properly in GarageBand!

With the following setup, I'm able to do the hi-hat pedal close sound, closed and open hi-hat sounds (there's only 2 distinct sounds unfortunately but that's all that GarageBand offers because the sounds are designed for keyboards):

MIDI Setting Screen
MIDI Settings that work with GarageBand hi-hats.png
MIDI Settings that work with GarageBand hi-hats.png (184.6 KiB) Viewed 1756 times


Settings for "Copy of GarageBand" MIDI Map
Settings for %22Copy of GarageBand%22 MIDI Map.png
Settings for %22Copy of GarageBand%22 MIDI Map.png (201.67 KiB) Viewed 1756 times


Notice in the second picture, I had to select Foot Pedal for the CC: option. One strange thing I noticed though was in order to choose "Foot Pedal" I had to first uncheck either or both of the checkboxes on the MIDI Settings screen under the Hihats section ("Only send openness before note" and "Open or closed only") otherwise the CC: options are not visible at all. Anybody know why this happens?

Anyway, I'm very happy I figured this out and wanted to share this with other users who want to try using GarageBand's drum sounds.

As I got to the end of writing this thread, I just saw Richard's update, so I will try that option with the built-in "GarageBand" preset and report back if that works for me or not.
eriklharper
 
Posts: 11
Joined: Tue Jun 05, 2018 12:31 am

Re: Hi hat help

Postby Richard » Thu Jun 07, 2018 10:23 pm

Good to hear you found a solution that works for you and thanks for posting the instructions.

It's a bit strange though. The reason why the 'CC' options disappear when the 'Open or closed only' option is ticked is because Aerodrums doesn't send any CC data for the hihat when this option is ticked, so the CC settings are irrelevant. Therefore I would be surprised if the 'Foot pedal' option actually made a difference.

Just to clarify further....the continuous control (CC) data is sent by Aerodrums to indicate the openness level of the hihat at any moment so that when the hihat is hit, the host knows how open the hihat was when it was hit. The host can use this continuous stream of openness values to do fancy things like determine if the hi-hat pedal was "splashed" with the foot instead of pressed firmly down. If I recall, certain hosts (Cubase being one) didn't like this constant stream of data so the option was added to 'Only send openness before note'. That fixed those issues. Other hosts (e.g. GarageBand) weren't set up to take hihat openness from CC data, i.e. they didn't support continuous hihat openness and only had MIDI notes that corresponded to hitting a fully closed hihat or a fully open hihat with no inbetweens. As such, the 'Open or closed only' option was added which tells Aerodrums not to send CC data for the hihat and instead to send one note for closed hihat hits and another note for open hihat hits.

...This is why the CC options disappear when you select 'Open or closed only'. It's because they are irrelevant. As well as the CC options disappearing, the screen also changes so that you can now specify which MIDI note gets sent for closed hihats hits and open hihats hits. I hope that answers your question and clears things up.

In my case I was using the GarageBand MIDI map preset that comes with Aerodrums and it was working fine. I suggest trying this one more time and see if it behaves well for you.
Richard
 
Posts: 642
Joined: Wed Feb 26, 2014 1:45 am

Previous

Return to General

cron