tried it all - still latency - W10 MS Surface Book

tried it all - still latency - W10 MS Surface Book

Postby guasaman » Sun Oct 09, 2016 12:49 am

I have a considerable latency in my current setup that makes AD unusable really. I have tried everything I could find to solve this and still no luck. The weird thing is that AD worked just fine with an older laptop I had and exactly the same setup, but on this new MS Surface book no luck so far. A bummer as tomorrow I had a perfect gig for ADs, but oh well. Any help will be appreciated.
The latency is bad enough that if I hit my leg with the stick, I can hear a tu-ka, tu being the sound of the stick hitting my leg, and Ka the AD sound coming out of the speaker/headphone.

Details:
HW: High end MS Surface Book, 16GB RAM, 512 GB SSD, dual video card. Realtek sound speakers and headphones.
Things I tried:
Turn the latency bar all the way to the left
Configured AD to use the NVIDIA card. So the video green/red thingy is always on green.
Ensured the realtek headphone out settings (I connect the laptop to a small Roland Cube) are configured to use 44100.
Tried with headphones, same latency issue.
guasaman
 
Posts: 5
Joined: Tue May 17, 2016 2:07 am

Re: tried it all - still latency - W10 MS Surface Book

Postby Richard » Sun Oct 09, 2016 10:12 pm

Which audio device setting did you choose from the Latency screen?
We have always seen very low latency when the Exclusive WASAPI option is chosen. Let us know if that's not working or available.
The usual fallback is to install ASIO4ALL and choose the ASIO option within Aerodrums and the last resort fallback is to buy a cheap USB sound card and use that instead of the Realtek.
Richard
 
Posts: 630
Joined: Wed Feb 26, 2014 1:45 am

Re: tried it all - still latency - W10 MS Surface Book

Postby guasaman » Mon Oct 10, 2016 4:36 am

I am using exclusive WASAPI. I will try with the other audio option and see. Thanks!
guasaman
 
Posts: 5
Joined: Tue May 17, 2016 2:07 am

Re: tried it all - still latency - W10 MS Surface Book

Postby slavedave » Fri Oct 14, 2016 9:20 am

Have you tried installing DPClatency checker:
http://www.thesycon.de/deu/latency_check.shtml

or Latency Moniter:
http://www.resplendence.com/latencymon

Both are tools to help you to ascertain how well set up your system is for audio latency. The former is more basic but gives you an easy, visual read out of realtime latency performance and will highlight spikes that you can then monitor as you make adjustments to your system. I found the two biggest issues with my system was having the wifi turned on and running antivirus programmes, so now when I play live with my laptop I ALWAYS disable my internet hardware/ wifi hardware in device manager and then temporarily disable my AVG antivirus for the duration of the session. The latency spikes disappear!

Latency Moniter can home in on specific causes of latency but you start hitting system settings quite quickly that are way beyond my technical knowledge so I tend to not go into many of the highlighted causes of latency. You may find that info more interesting than I do.

All the best!
slavedave
 
Posts: 37
Joined: Thu Jan 08, 2015 1:16 pm

Re: tried it all - still latency - W10 MS Surface Book

Postby guasaman » Sat Nov 05, 2016 1:46 am

Thanks. I tried with the latency tools, and disabling various devices. The DPC latency checker shows a yellow graph with an average ~1200us. It sometimes states the computer should be fine, and at other times that there are drivers that could cause issues. Still after disabling everything I can, the latency stays in yellow. And this is without trying AD. And when I try AD, it has a latency that makes it unusable.
It looks like there is a luck factor for ADs to work well or not, and/or I cant find what is causing the latency.
If anyone has other ideas, they are welcome.
guasaman
 
Posts: 5
Joined: Tue May 17, 2016 2:07 am

Re: tried it all - still latency - W10 MS Surface Book

Postby Drumaster » Wed Nov 23, 2016 2:12 pm

Hello,

I have the exact same issue with my Microsoft Surface 4 Pro 256GB SSD 8GB of RAM. No matter what I do (I reduced the latency to its lowest threshold via Aerodrums software, I use exclusive WASAPI api, the soft runs at 125fps...), I still get this awfull latency that prevents me from playing... I start thinking that this issue is related to any Surface device.....

guasaman > Do you have any update about your issue or do you still have the same as me?

Help would be much appreciated.... thanks!
Drumaster
 
Posts: 3
Joined: Wed Nov 23, 2016 1:56 pm

Re: tried it all - still latency - W10 MS Surface Book

Postby Richard » Wed Nov 23, 2016 3:33 pm

You could try purchase a cheap external USB sound card such as this one:
https://www.amazon.co.uk/Sabrent-Extern ... +interface

It's likely that would solve the problem. It has worked for us in the past to get Aerodrums working with minimal latency on a cheap Windows tablet.
Richard
 
Posts: 630
Joined: Wed Feb 26, 2014 1:45 am

Re: tried it all - still latency - W10 MS Surface Book

Postby Drumaster » Wed Nov 23, 2016 3:39 pm

You mean this cheap usb sound card is better than the one in the Surface 4 Pro (which is not meant to be a cheap Microsoft tablet, as it costs 1,449€....)??

Thanks.
Drumaster
 
Posts: 3
Joined: Wed Nov 23, 2016 1:56 pm

Re: tried it all - still latency - W10 MS Surface Book

Postby Richard » Wed Nov 23, 2016 3:53 pm

I'm not saying it's better. It could be explained by other reasons, such as poor implementation of the Exclusive WASAPI driver software for the Surface Pro 4.
Richard
 
Posts: 630
Joined: Wed Feb 26, 2014 1:45 am

Re: tried it all - still latency - W10 MS Surface Book

Postby Drumaster » Wed Nov 23, 2016 3:59 pm

Ok thanks, gonna try that as it's cheap anyway and as I don't find any other solution.
Drumaster
 
Posts: 3
Joined: Wed Nov 23, 2016 1:56 pm

Next

Return to Support

cron