Nvidia Card GTX960 does not manage framerate

Nvidia Card GTX960 does not manage framerate

Postby JRC » Tue Apr 12, 2016 4:09 pm

as per title:

Got a brand new ASUS Zenbook Pro (about 1300 GBP). It's 4-core i7, 16 GB RAM, 512 SSD, Nvidia GTX 960m-card. The whole enchilada.

When only using Aerodrums there are no issues with the framerate. When using it to send MIDI to external VST:s (Addictive Drums, Superior Drummer ...)
the camera framerate drops on a regular basis to about 80, and then back up. This is not acceptable of course. I have:

- Disabled Vsync for Aerodrums
- Also created a profile for both Aerodrums and VST:s in Nvidia:s panel in order to disable Vsync.
- I always disable Internet, any potential antivirus programs, bluetooth, prioritize background services, disable USB conserving power etc. so all CPU power is used in an optimal fashion for the applications.
- I use Graphics mode 3 (Same as above except the graphics are simplified)

Does not cut it. Still drops.

Should mention that my older netbook from Acer with an old integrated graphics card manages this substantially better, and it cost a fifth of this machine.

Any input?
JRC
 
Posts: 27
Joined: Fri Mar 25, 2016 12:05 am

Re: Nvidia Card GTX960 does not manage framerate

Postby Richard » Tue Apr 12, 2016 9:54 pm

It sounds like this is a CPU performance issue rather than a graphics performance issue. Some of those VSTs can be very demanding. They might have options to reduce the CPU load at the expense of quality, I'm not sure.

On my old laptop I've been able to fix some performance issues by either minimizing the Aerodrums window while drumming or by minimizing the DAW/VST window while drumming. I would try both of these to see if they behave better.

Also, if you notice a correlation between frame rate drops and how "intensely" you're drumming, it might also help to set the MIDI note filtering in Aerodrums to prevent notes being sent for very quiet hits. This should reduce demand on the VST and might prevent the frame rate drops.
Richard
 
Posts: 600
Joined: Wed Feb 26, 2014 1:45 am

Re: Nvidia Card GTX960 does not manage framerate

Postby JRC » Tue Apr 12, 2016 10:27 pm

Thanks for input Richard, but this is definitely not a CPU issue. Bear in mind it works almost flawlessly with my older netbook carrying a Pentium N3540 which does not come near an i7 Haswell on 3GHz.
Minimizing windows has been done. Also tried the integrated graphics card on each respectively and simultaneously.
JRC
 
Posts: 27
Joined: Fri Mar 25, 2016 12:05 am

Re: Nvidia Card GTX960 does not manage framerate

Postby JRC » Wed Apr 13, 2016 6:18 pm

Would you recommend adjusting other values commonly found in the control panel for the graphics card? I would assume you want as much power to go to the GPU as possible, or is that a logical fallcay?
I have played around with some of the bolded settings below:


Ambient occlusion: [Quality]
Antistropic filtering: [16x or Application controlled]
Antialiasing - fxaa: [On]
Antialiasting - gamma correction: [On]
Antialiasing mode: [Application controlled]
antialiasing setting: [Application controlled]
antialiasing - transparency: [Application controlled]
CUDA - GPUS: [All]
maximum pre-rendered frames: [Application controlled]
multi-display mixed gpu acceleration: [Single display performance mode]
Power management mode: [High Quality]
DSR [check off all the boxes]
Texture filtering - negative LOD bias: []
Texture filtering - quality: [High Quality]
Threaded optimization: [ON]
Triple buffering: []On
Vertical sync: [Off]
JRC
 
Posts: 27
Joined: Fri Mar 25, 2016 12:05 am

Re: Nvidia Card GTX960 does not manage framerate

Postby Richard » Wed Apr 13, 2016 7:03 pm

I would try graphics mode 4 where nothing is displayed. You won't be able to see the frame rate indicator but you should be able to tell by drumming if it's behaving well or if the frame rate is still dropping. If there's still a problem then it's almost certainly not a graphics issue as we're not displaying anything in this mode.

As for those graphics settings, really the only ones that should matter are vertical sync which should be off, and possibly power management mode. I don't think any of the others will help.
Richard
 
Posts: 600
Joined: Wed Feb 26, 2014 1:45 am


Return to General