upgrading sound card and WASAPI

upgrading sound card and WASAPI

Postby charlton1966 » Mon Feb 22, 2016 11:15 am

Unfortunately my aero drums wont work properly on either of my PC's.
Firstly on one of the PC's ,Aerodrums tells me I need to upgrade my graphics card to include opengl2.0.I have an intel(r) graphics card that research suggested is not compatible with opengl2.0..so fail there. Any suggestions without replacing the current gtraphics card manually.
Secondly on the other PC there is latency with the in house sound card. I have Asioforall installed which when clicked on in latency page on Aerodrums set up page gives no sound at all .I note that WASAPI is recommended I have looked how to download this but after a few hours, was just going round in circles.

Any suggestions most appreciated.
charlton1966
 
Posts: 1
Joined: Mon Feb 22, 2016 11:04 am

Re: upgrading sound card and WASAPI

Postby Richard » Mon Feb 22, 2016 10:23 pm

Sorry to hear about this. For the PC with the Intel graphics card, all I can suggest is to try find more recent drivers if they exist.

For other PC, I'm not sure why ASIO4ALL isn't working for you, just make sure you don't have any other program running that might be taking exclusive control over your sound card. WASAPI has been a feature of Windows since Vista. It's possible that your sound card does not support it but I haven't seen this before. Can you tell me what audio device options you see on the Aerodrums Latency screen (or post a screenshot)? The first option should be Exclusive WASAPI, followed by Shared WASAPI. Are these grayed out?
Richard
 
Posts: 599
Joined: Wed Feb 26, 2014 1:45 am

Re: upgrading sound card and WASAPI

Postby Richard » Mon Feb 22, 2016 10:28 pm

I forgot to mention that you may need to enable access to Exclusive WASAPI before you can select it in Aerodrums.
You can do that as follows:

    Go to Windows Control Panel –> Sound –> Playback tab
    Select the audio playback device that you are currently using and then go to Properties -> Advanced tab
    In the Default Format drop down menu, select a format with a 44100Hz rate. This is required for Shared WASAPI.
    In the Exclusive Mode section, tick both checkboxes.
Richard
 
Posts: 599
Joined: Wed Feb 26, 2014 1:45 am


Return to Support

cron