Problems enabling WASAPI

Problems enabling WASAPI

Postby gdrago » Sat Feb 04, 2017 3:41 pm

Hello guys,

So I received my aerodrum kit yesterday, and the WASAPI options in the latency screen are greyed out.
When trying to follow the troubleshooting steps, there's a problem. I can't change the default sample rate of my sound device to 44.1 kHz. When for example I try to configure my laptop speakers, there are only the options to select 16-bit 48000 Hz and 24-bit 48000 Hz.

How can I change it to 44100 Hz? or are there other options to enable the reduced latency settings?
gdrago
 
Posts: 1
Joined: Sat Feb 04, 2017 3:35 pm

Re: Problems enabling WASAPI

Postby Richard » Mon Feb 06, 2017 1:41 pm

Unfortunately some sound cards don't allow the sample rate to be set to 44.1 kHz.
In this case I recommend installing ASIO4ALL (from http://www.asio4all.com) and enabling the ASIO device setting from the Aerodrums Latency screen.
The ASIO4ALL control panel will let you configure the buffer size so you should be able to set it to its lowest value to get very low latency.

If for some reason this doesn't work, another option would be to buy a cheap USB sound card that supports the Exclusive WASAPI mode.
The one we have tested ourselves is the ""Sabrent USB audio stereo sound adapter" which is currently $7 on Amazon:
https://www.amazon.com/Sabrent-External ... B00IRVQ0F8
Richard
 
Posts: 632
Joined: Wed Feb 26, 2014 1:45 am


Return to Support