Aerodrums setup with BFD3 in Studio One

Post Reply
Posts: 1
Joined: Wed Jan 16, 2019 5:23 am

Aerodrums setup with BFD3 in Studio One

Post by Mikiko » Wed Jan 16, 2019 5:56 am

Hi All,

I have Aerodrums and BFD3.
Been using BFD3 for a while, aerodrums is new.
Im having trouble setting the midi input up to get aerodrums to trigger in BFD3.

I used LoopBe1 as the virtual port to send the midi from Aerodrums into Studio One and it appears to be working as I can see midi notes being played when I click the midi icon bottom left in Studio One.

How do I set up the instrument track to get the midi controller to be Aerodrums and the instrument to be BFD3?

I use a keyboard midi controller and had no issues at all setting that up.

I tried youtube and searching here but didnt find anything.
Any help appreciated its driving me mad haha,


Posts: 765
Joined: Wed Feb 26, 2014 1:45 am

Re: Aerodrums setup with BFD3 in Studio One

Post by Richard » Fri Jan 18, 2019 11:30 am

First of all, if you haven't watched them yet, it might be useful to watch the video tutorials here: ... -samplers/ particular, to see how to set up LoopBe1 and configure Aerodrums to output MIDI.

To test this, perhaps you can try run the standalone version of BFD3 (i.e. without running Studio One) and see if that works with Aerodrums first. If you don't succeed with that, please let me know.

I'm not familiar with Studio One myself but basically you will need to choose LoopBe as the source of MIDI input (also making sure that LoopBe is also selected in the MIDI screen within Aerodrums). Perhaps this page will help:

Please note that if Aerodrums is set to use Exclusive WASAPI for audio output (the recommended option) then Aerodrums will take exclusive control of the sound card, thus preventing Studio One or other software from being able to output audio. So please test that audio is playing from within Studio One after you have set up and are running Aerodrums.

Let us know if you manage to get things working. Good luck!

Post Reply