Latency persists

Latency persists

Postby paulobucho » Wed Aug 20, 2014 11:44 pm

Hi!

I moved temporary to another country and i bought AeroDrums to not stoping playing.

My laptop is a i5 2.3 ghz with 6 gb Ram.

I play with Midi Only in the Midi Output Mode, sending the Midi output to default.

Does it make any sense still having some latency?

It is necessary working with ASIO4ALL driver?

I am getting frustrated.

PB from Portugal
paulobucho
 
Posts: 30
Joined: Fri Aug 08, 2014 10:27 am

Re: Latency persists

Postby Richard » Thu Aug 21, 2014 1:39 am

Hi, the most likely cause of latency is the choice of audio output device and the way it's configured. Can you tell me what host/DAW you're using to receive the MIDI and what device it's using for audio output? I would recommend trying ASIO4ALL if you haven't done so already.

Have you also tried running Aerodrums in non-MIDI mode? Here (assuming you're running Windows) you should be using the Exclusive WASAPI option with a very small buffer size. These options can be set from the Latency menu in Aerodrums. Is the latency acceptable in this case?
Richard
 
Posts: 630
Joined: Wed Feb 26, 2014 1:45 am

Re: Latency persists

Postby paulobucho » Fri Aug 22, 2014 9:42 am

Yes, i alread install ASIO4All driver and in fact the latency got better. But i am still lost, what values should i put??
paulobucho
 
Posts: 30
Joined: Fri Aug 08, 2014 10:27 am

Re: Latency persists

Postby Sipaliwini » Fri Aug 22, 2014 10:31 am

Glad the latency has improved with Asio4all, here is how to improve it further.

1) When you launch your DAW/Sampler, you should see Asio4all's icon (it is green and looks like a "Play" button) appear in the Windows notification area in the task bar (bottom right corner by default). Click on that. In the dialog that appears, there is a slider that says "ASIO Buffer Size" at the bottom. Lower it to the lowest value that doesn't cause audio glitches.

2) (Only if the latency is still not satisfactory) In Control Panel -> Hardware and Sounds -> Playback Tab -> Default Device selected -> Properties button -> Advanced tab -> Default Format drop down, it may help if you select a mode with a 44100Hz sampling rate, because it will save Asio4all the task of resampling if it has to.

Note that when in the "MIDI Only" mode, none of the settings on the latency screen of Aerordrums have any effect (except for the drum hit detection sensitivity). This is because it is not Aerodrums that is outputting the sound, but your DAW/Sampler. So you don't have to worry about those settings.

Let us know how it goes.
Sipaliwini
 
Posts: 395
Joined: Thu Jan 16, 2014 12:40 pm


Return to Support