High Latency

High Latency

Postby schputim » Sun Feb 19, 2017 7:14 pm

Hi! Recently received my aerodrums, lifelong dream coming true of finally being able to play on my own drums. However, I have a big latency, to the Point where I can't use the aerodrums because it's so annoying. I have no way to measure it, but I would say atleast 300ms. Here are a few Information:

- I have an XPS 15 9560, i7, 16gb ram. Processing power can't be a Problem. The top left thingy is always green. No power saving mode.
- Sound Settings are correct, same as you wrote in the Troubleshooting-page (41400hz).
- buffer slider is on the lowest

what else can I do? sensitivity and tracking of the balls are perfect, it's just the latency that's throwing me off!
schputim
 
Posts: 5
Joined: Sun Feb 19, 2017 6:12 pm

Re: High Latency

Postby Richard » Mon Feb 20, 2017 11:50 am

Since I haven't seen an issue like this when using Exclusive WASAPI I would double-check the following:
1. That you have selected the Exclusive WASAPI option from the Aerodrums Latency screen
2. That you have ticked the two Exclusive Mode checkboxes within Windows Control Panel by following the instructions here: http://aerodrums.com/fixit/#cab
If this is the case and you still have noticeable latency then I suggest installing ASIO4ALL from http://www.asio4all.com which will allow you to select an ASIO option from the Latency screen within Aerodrums. ASIO4ALL has it's own "buffer size" setting; you should be able to decrease this to its minimum value of 64.
If this doesn't work then it would appear that your sound card is not capable of achieving very low latency.
In this case, you could resort to buying a cheap USB sound card that supports the Exclusive WASAPI mode.
The one we have tested ourselves is the ""Sabrent USB audio stereo sound adapter" which is currently $7 on Amazon:
https://www.amazon.com/Sabrent-External ... B00IRVQ0F8
Richard
 
Posts: 563
Joined: Wed Feb 26, 2014 1:45 am

Re: High Latency

Postby schputim » Mon Feb 20, 2017 10:03 pm

Thank you so much Richard! I can't believe my Sound Card wouldn't be good enough for this, it's a brand new 1700$ Laptop! I will try out your suggestions in a while!
schputim
 
Posts: 5
Joined: Sun Feb 19, 2017 6:12 pm

Re: High Latency

Postby Goebs80 » Fri Mar 03, 2017 6:28 pm

I just purchased Aerodrums. Unfortunately, I'm encountering the same problem. I downloaded and installed ASIO4ALL, reduced the buffer to 64, but still had no luck. I then purchased the Sabrent USB audio stereo sound adapter, which I just tried using, and am having no luck either. My computer recognizes the Sabrent, I have switched my sound playback default to the Sabrent USB device. I've gone into properties --> advanced and verified that the Sabrent is on 44100 Hz (CD Quality) and that both boxes in Exclusive Mode are checked. However, when I go back into Aerodrums and select USB Audio Device in the latency section, I'm still only able to choose the Windows Default option. Everything else is greyed out. Help!
Goebs80
 
Posts: 1
Joined: Fri Mar 03, 2017 6:18 pm

Re: High Latency

Postby Richard » Mon Mar 06, 2017 12:19 pm

I believe Yann helped you solve this through our support email. For others who might run into this same problem with the Sabrent, the fix was to uninstall ASIO4ALL.
Richard
 
Posts: 563
Joined: Wed Feb 26, 2014 1:45 am

Re: High Latency

Postby schputim » Tue Apr 25, 2017 8:44 pm

Alright man, I give up. I bought that soundcard you linked, but the latency is still here... 0.2s latency just makes it unplayable... I spent so much time and money on this thing, I have a brand new 1700$ laptop, I just can't believe that the pc isn't good enough. I spent hours and hours going through every shitty setting, in your program, in the whole windows system, looking up reasons on the internet (I bought it in january and I've been fidgeting around with it since then)... YET it still doesn't work...

I know it's not your fault, I sincerely thank you for your help. Maybe I'll do a video or something to "proof" you that I did every single thing and ticked every setting you mentioned. It breaks my drummer-heart, who can't have a real drum because of the noise :(.
schputim
 
Posts: 5
Joined: Sun Feb 19, 2017 6:12 pm

Re: High Latency

Postby Richard » Wed Apr 26, 2017 11:34 am

I'm sorry to hear that. I did some research on the XPS 15 9560 and found quite a few discussions about poor audio latency on this laptop. If it's not too late for you I would consider returning your laptop to Dell for a refund or a different model.

There might be some things you could try like disabling your WiFi adapter and Bluetooth, or updating your Intel graphics drivers (https://blog.anichin.com/xps-15-9560pre ... kaby-lake/).

I also recommend you download and run LatencyMon which will report how suitable your computer is for handling low latency audio:
http://www.resplendence.com/latencymon

Here are some other links that might be worth going through:
https://www.reddit.com/r/Dell/comments/ ... on_a_9560/
https://www.reddit.com/r/Dell/comments/ ... tuttering/
https://www.reddit.com/r/Dell/comments/ ... s_15_9560/
http://forum.notebookreview.com/threads ... 60.801763/
Richard
 
Posts: 563
Joined: Wed Feb 26, 2014 1:45 am

Re: High Latency

Postby schputim » Fri Apr 28, 2017 7:44 am

you're incredible Richard. I will go through that one more time. Returning it might be too complicated, as I desperately need it for my studies and I doubt that anything is wrong with it (it's working perfectly otherwise) and I don't think I get a new product after more than 2 months.
schputim
 
Posts: 5
Joined: Sun Feb 19, 2017 6:12 pm

Re: High Latency

Postby FortMonkey » Sun Jul 23, 2017 7:50 pm

Just wanted to add to this, as I've troubleshooted several computers for latency in the past.

LatencyMon is great, but not compatible with Windows 7. If you're on 7, check out DPC Latency Checker for an accurate readout: http://www.thesycon.de/eng/latency_check.shtml

I strongly agree with returning a computer that has high latency. Latency (and real-time performance) doesn't matter to most computer users, which is why you will never find specs listed by the manufacturers. Only rarely will you even find benchmarks from review publications, and even then they're often questionable and incomplete.

The main culprit is the motherboard, so there is little that you can do to fix it after the fact. BIOS optimizations and other hacks might make the situation marginally better, but a machine with good latency should run really well stock.

The Dell XPS is a great overall laptop, but if you're having latency issues with it, you'll get poor performance out of ANY live music application (drums, keyboards, recording, etc.)
FortMonkey
 
Posts: 7
Joined: Sat Jul 22, 2017 2:24 am


Return to General

cron