Latancy and midi issues

Richard
Posts: 787
Joined: Wed Feb 26, 2014 1:45 am

Re: Latancy and midi issues

Post by Richard » Fri Oct 02, 2020 2:48 pm

Ok, interesting that you're getting the same problem with AD2. I tested it just now and the hi-hat behaviour is working fine for me. Here is how the setup looks on my end...

Image

This shows how the hihat looks in the Addictive Drums 2 MIDI map preset within Aerodrums. As you can see, MIDI note 8 is sent for normal hihat hits and note 7 is sent for accented hits. 'Foot pedal' is selected in the CC field which corresponds to CC 4 (equivalent to choosing 'Other' and setting a value of 4).

Image

This shows how the hihat looks on the Additive Drums 2 side with the default AD2 Standard map chosen. CC Reverse should be checked and CC Number should be set to 4. Note 8 should map to CC Hihat Tip and note 7 should map to CC Hihat Shaft. You can see this is the keyboard view on the right hand side of the window.

If this all looks the same on your end, can you try use some MIDI monitor website in your browser. The one I tried was midimonitor.com. If you hit the hihat in Aerodrums while you have this open in your browser it will show you the MIDI data being sent from Aerodrums.

You should see something like this:

Image

If you're hitting the hihat you should see either note #8 or note #7 being sent and you should see CC#4 messages being sent with values between 0 and 127 depending on the openness. Can you check if this is working? If it's not working then we know that the problem is on the Aerodrums side, not the AD2 side. Thanks.

Wolfgang
Posts: 105
Joined: Tue Jul 07, 2015 11:36 am

Re: Latancy and midi issues

Post by Wolfgang » Fri Oct 02, 2020 3:18 pm

This are my map files for AD1 and AD2. I'm not using Addictive anymore. I remember that I've done something to them, but I don't remember what. I just have installed all the stuff and tested them and the Hi-Hat is working.
AD1&2.7z
(1.35 KiB) Downloaded 48 times
Edit
Sorry Richard, I haven't seen your last message.

saito
Posts: 10
Joined: Sat Sep 26, 2020 7:50 pm

Re: Latancy and midi issues

Post by saito » Fri Oct 02, 2020 4:02 pm

Hi, i checked the midi list using midimonitor and it looks the same as the photos you sent.
Using the hihat pedal - note 48 and velocity
Open the hihat gives the list of values ( cc#4 and values between 0 to 127
Normal closed hihat - note 8 and velocity
Everything seems to be working

saito
Posts: 10
Joined: Sat Sep 26, 2020 7:50 pm

Re: Latancy and midi issues

Post by saito » Fri Oct 02, 2020 4:14 pm

I noticed that only when i hit the hihat hard, its triggering the HH shaft(note #7)
Its normal?

Richard
Posts: 787
Joined: Wed Feb 26, 2014 1:45 am

Re: Latancy and midi issues

Post by Richard » Fri Oct 02, 2020 5:38 pm

That's very strange. Your MIDI monitor results would suggest that everything is fine on the Aerodrums side so I'm not sure right now where the problem could be. I will think about it.

Yes, it's normal for note #7 to be sent for hard hihat hits. Similar to the way the snare drum is configured to trigger normal snare hits when you hit soft and rimshot hits when you hit hard, the hihat is similarly configured to send one note type when you hit soft and another when you hit hard. The idea here is that, in AD2, soft hits will trigger "tip" hits and hard hits will trigger "shaft" hits. The note sent for soft/hard hits can be changed from the MIDI Maps screen in Aerodrums and the velocity threshold (that determines what a soft vs hard hit is) can be changed from the "Adjust Drums -> MIDI" screen.

Wolfgang
Posts: 105
Joined: Tue Jul 07, 2015 11:36 am

Re: Latancy and midi issues

Post by Wolfgang » Fri Oct 02, 2020 6:05 pm

I have installed Addictive Drums 1 & 2 this morning, my two map files I’ve posted beyond are working, I had a bit forgotten how good the Hi-Hats are working in Addictive. If someone want to verifiy my settings . . .

Wolfgang
Posts: 105
Joined: Tue Jul 07, 2015 11:36 am

Re: Latancy and midi issues

Post by Wolfgang » Sun Oct 04, 2020 11:52 am

I think I remember what I did.

I was using MIDI before there was the extended MIDI configuration in Aerodrums, and we had to load MIDI maps from an archive into the corresponding VSTI. I’m still doing like this, because I find this procedure much more flexible when you are using more than one VSTI.

In my 7z archive are two files, Aerodrums.ADMap and Aerodrums.AD2Map. I’ve md5 checked my Aerodrums.ADMap against this one in Richard’s archive and it’s the same file. So I haven’t done anything to this one, and Richard’s file works.

But, if I remember right, there wasn’t an AD2map in this archive, so what I did was to create my AD2Map for Aerodrums (Aerodrums.AD2Map in my archive).

saito
Posts: 10
Joined: Sat Sep 26, 2020 7:50 pm

Re: Latancy and midi issues

Post by saito » Mon Oct 05, 2020 6:37 pm

Ok guys, problem solved. My bad for trying only to open the AD from inside a DAW (FL studios) For some reason its having the hihat openness issue. But when i start the AD normal the hihat is working. Though i must say its having some glitches and hicups. There's an obvious transit between open and closed hihat, its not smooth.. And the hihat tends to stay open after im closing it using the foot pedal(tried to play with sensitivity and limiter)
Either way, thanks a lot guys for your full answers, tips and patience.

Wolfgang
Posts: 105
Joined: Tue Jul 07, 2015 11:36 am

Re: Latancy and midi issues

Post by Wolfgang » Mon Oct 05, 2020 7:17 pm

saito wrote:
Mon Oct 05, 2020 6:37 pm
Though i must say its having some glitches and hicups. There's an obvious transit between open and closed hihat, its not smooth.. And the hihat tends to stay open after im closing it using the foot pedal(tried to play with sensitivity and limiter)
Here you can adapt different degrees of openness to your foot.
ADPedalCC.jpg
ADPedalCC.jpg (21.86 KiB) Viewed 1141 times

Post Reply